Mailer To Go issues sending email
Incident Report for Crazy Ant Labs
Resolved
This incident has been resolved.
Posted Oct 31, 2021 - 14:29 UTC
Update
We are continuously working to solve the issues with our service provider.
Posted Oct 27, 2021 - 12:27 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 22, 2021 - 05:40 UTC
Identified
We are experiencing issues sending email messages from domains added in us-east-1 due to abuse by spammers.
Posted Oct 20, 2021 - 05:40 UTC
This incident affected: Mailer To Go (SMTP).