Due to AWS's incident some components are still impacted

Incident Report for Crazy Ant Labs

Resolved

Our services were impacted by the large event of our cloud provider.

The incident would have caused varying types of degradation of our services - inability to log in to our dashboard, increased error rates in API calls, high latency, and other services, integrations and channels not working. During this incident, our Engineering teams worked to work through all processing back logs and rebalance the service through other available regions.

This incident is now resolved, and all services are now working as expected.
Posted Oct 20, 2025 - 22:40 UTC

Update

Please use this server host name to connect summer-wind-35319.sftptogo.com. This server name is very secure and many FTP clients that lack the newest security algorithms will not be able to connect to it. Due to AWS's incident the following components are still impacted, SFTP To Go's audit logs and SSO authentication and Cron To Go's processing engine. Support chat is lagging so new tickets are slow to get a response.
Posted Oct 20, 2025 - 18:11 UTC

Update

Due to AWS's incident the following components are still impacted, SFTP To Go's audit logs and SSO authentication and Cron To Go's processing engine. Support chat is lagging so new tickets are slow to get a response.
Posted Oct 20, 2025 - 17:02 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 10:53 UTC

Monitoring

Due to AWS's incident the following components are still impacted, SFTP To Go's audit logs and Cron To Go's processing engine
Posted Oct 20, 2025 - 10:35 UTC
This incident affected: SFTP To Go (Web Interface, SFTP / FTPS) and Cron To Go (Heroku).