Mailer To Go email sending paused for US East region
Incident Report for Crazy Ant Labs
Resolved
This incident has been resolved.
Posted Sep 12, 2021 - 15:45 UTC
Identified
Our service provider has just paused our ability to send emails as a security measurement for high complaint rate in the US East region. We are working closely with them to restore the service ASAP.
Posted Sep 09, 2021 - 12:17 UTC
This incident affected: Mailer To Go (SMTP).